Je souhaite obtenir des informations sur une formation complète concernant le thème DIVI dispensé
par un organisme de formation certifié par l’état.
Que la formation soit finançable par mon CPF (idéalement) ou autre


Les éditeurs WordPress découvrent que Gutenberg 10.2 (publié le 17 mars 2021) est à l’origine de « bugs fatals » en raison d’un problème d’incompatibilité avec WordPress. Un éditeur a suggéré que les mises à jour automatiques de Gutenberg exécutent une vérification de compatibilité et déclenchent une alerte en cas d’incompatibilité.

WordPress Gutenberg

Gutenberg est un éditeur de site WordPress visuel qui représente un changement radical par rapport à la façon dont les sites Web ont été construits nativement dans le noyau WordPress.

Il permet aux éditeurs de créer des sites Web à l’aide de l’interface utilisateur graphique de blocs. Par exemple, une page Web peut être représentée sous forme de blocs qui représentent le haut de la page (en-tête), la zone de contenu, la barre latérale, etc.

La publicité

Lisez ci-dessous

Gutenberg n’est pas encore terminé, l’édition complète du site n’est pas encore terminée. En tant que technologie qui n’est pas encore complètement développée, des erreurs sont bien entendu à prévoir, voire à prévoir.

Erreur fatale Gutenberg 10.2

Un membre du groupe Facebook WordPress avancé a lancé une discussion pour documenter un bogue fatal survenu lors de la mise à jour vers Gutenberg 10.2.

Le message a déclaré que le bogue fatal s’est manifesté dans la version 5.6 de WordPress. Il a également été noté qu’un article de GitHub sur le bogue notait que Gutenberg 10.2 est également incompatible avec WP 5.5.

Chronologie des versions de WordPress et Gutenberg

WordPress 5.7 est sorti le 9 mars 2021.

L’éditeur du site Gutenberg 10.2 est sorti un peu plus d’une semaine plus tard, le 17 mars 2021.

Les éditeurs de sites Gutenberg qui ont mis à niveau vers WordPress 5.7 puis vers Gutenberg 10.2 ne devraient pas voir cette erreur.

La publicité

Lisez ci-dessous

Les éditeurs qui ont mis à jour vers Gutenberg 10.2 mais pas WordPress lui-même peuvent rencontrer le bogue fatal.

L’erreur grave se produit particulièrement souvent avec les éditeurs qui configurent leurs installations Gutenberg de manière à ce qu’elles soient automatiquement mises à jour (mise à jour automatique), mais ne sont pas configurées pour la mise à jour automatique de WordPress lui-même.

Une erreur a été trouvée chez l’officier Forums de support WordPress Gutenberg Cependant, au moment d’écrire ces lignes, il n’y avait pas de suivi.

Le problème d’erreur grave a également été documenté sur l’agent Page Gutenberg GitHub.

À partir du rapport GitHub:

« Après la mise à jour vers 10.2.0, j’ai reçu un e-mail concernant un problème technique avec le plugin:

Une erreur E_ERROR s’est produite à la ligne 59 du fichier. J’ai pu désactiver le plugin via FTP. Maintenant, je ne veux pas l’activer tant que je ne sais pas que cela a été corrigé. « 

Une autre personne a écrit qu’elle avait remarqué la même chose et avait posté une capture d’écran:

Erreur fatale de WordPress GutenbergCapture d’écran de l’erreur fatale WordPress Gutenberg

L’utilisateur qui a posté la capture d’écran a suivi avec:

«J’utilisais WordPress 5.6. Après la mise à niveau vers la version 5.7, tout a fonctionné comme prévu. « 

La personne qui a lancé le message original sur GitHub a confirmé qu’il s’agissait également de son problème.

La publicité

Lisez ci-dessous

«Merci de m’avoir parlé de 5,7. Je n’avais pas mis à jour WP non plus, je peux maintenant réactiver Gutenberg. « 

Gutenberg 10.2 Incompatible avec les anciennes versions de WordPress

Une autre Rapport GitHub Gutenberg a souligné que Gutenberg 10.2 a causé de graves bogues dans les anciennes versions de WordPress.

Un éditeur utilisant la version 5.5.3 de WordPress a également signalé un bug fatal qui a provoqué un plantage.

La personne signalant le problème a confirmé qu’il était spécifique à Gutenberg 10.2, déclarant:

«J’ai désactivé le plug-in Gutenberg 10.2.0. Lorsque j’ai essayé de réactiver le plugin, l’erreur fatale est revenue.

Fatal error: Uncaught Error: Class 'WP_Block_Supports' not found in..."

La personne a fait une observation utile et a suggéré que Gutenberg 10.2 ne devrait pas être mis à niveau (ou automatiquement mis à niveau) vers les versions WordPress inférieures à WP 5.7.

«Il ne devrait pas être possible de mettre à jour automatiquement le plug-in Gutenberg sur un ancien site WP. Le résultat semble provoquer une erreur fatale. Comme il peut y avoir de nombreux sites Web qui rencontrent ce problème. « 

La publicité

Lisez ci-dessous

C’est une bonne solution au problème! S’il existe une incompatibilité connue entre Gutenberg 10.2 et les anciennes versions de WordPress, il est logique que les mises à jour automatiques s’arrêtent dans ces situations et génèrent un avertissement d’incompatibilité.

Les utilisateurs de l’éditeur de site Gutenberg qui publient avec une version de WordPress antérieure à WP 5.7 peuvent trouver conseillé de mettre à jour vers la dernière version avant de mettre à jour vers Gutenberg 10.2.

Devis

GitHub:
Gutenberg 10.2.0 verrouillé a provoqué un bug fatal # 29977

GitHub:
Bogue fatal dans le plugin Gutenberg 10.2.0 # 29972

Facebook: Groupe WordPress étendu (adhésion au groupe requise pour afficher)
Pour information, la dernière mise à jour du plug-in Gutenberg 10.2 provoque une erreur fatale





Source link

Recent Posts