Image d'archive WordPressorg

Plus tôt cette année Google a annoncé qu’il cesserait de suivre les gens via des publicités et mettra en œuvre un nouveau système appelé Apprentissage fédéré des cohortes (FLoC), un système il proposé pour la première fois en janvier 2021.

Essentiellement, FLoC permet à Google d’affecter des utilisateurs à une cohorte en fonction de leur activité en ligne, ce qui les maintient anonymat tout en leur fournissant une publicité ciblée. Cependant, l’introduction de FLoC ne s’est pas déroulée comme prévu par Google. Plus tôt ce mois-ci, un moteur de recherche axé sur la confidentialité DuckDuckGo a annoncé une mise à jour de son extension Privacy Essentials Bloquer FLoC. L’Electronic Frontier Foundation (EFF), d’autre part a publié un article expliquant à quel point FLoC est terrible. Peu après, Vivaldi et Brave ont annoncé qu’ils n’activeraient pas FLoC dans leurs navigateurs Web respectifs.

Maintenant, WordPress a a publié un article Proposition de traiter FLoC comme une menace pour la sécurité. Dans l’article, la société a déclaré qu’elle alimentait plus de 40% du Web et qu’elle avait le devoir de protéger ses utilisateurs.

Comme mentionné dans l’article du FEP, FLoC est le plus susceptible de conduire à l’emploi, au logement et à d’autres formes de discrimination.

WordPress a dit:

WordPress alimente environ 41% du Web – et cette communauté peut utiliser quatre lignes de code pour lutter contre le racisme, le sexisme, la discrimination contre les LGBTQ + et la discrimination contre les personnes atteintes de maladie mentale.

En conséquence, WordPress ajoute les quatre lignes de code suivantes pour désactiver automatiquement FLoC sur tous les sites Web:

function disable_floc($headers) {
    $headers['Permissions-Policy'] = 'interest-cohort=()';
    return $headers;
  }
 
add_filter('wp_headers', 'disable_floc');

Le code émet un en-tête de requête HTTP qui demande au navigateur de désactiver FLoC pour le site Web. La société a également constaté que les administrateurs qui souhaitent utiliser FLoC sur leur site Web ont probablement l’expertise nécessaire pour simplement remplacer le code de base.

Enfin, WordPress dit qu’il y a des problèmes lorsque tout le monde se connecte automatiquement sans comprendre pleinement la technologie et les ramifications. Pour cette raison, il a été décidé de désactiver FLoC pour tout le monde afin de protéger les intérêts des utilisateurs.

WordPress prévoit d’introduire le nouveau code avec Mettre à jour vers la version 5.8 Ceci est prévu pour juillet 2021. Cependant, étant donné que Google prévoit de déployer FLoC avant la mise à jour, WordPress envisage également de porter le code sur les versions existantes de la plate-forme et d’en amplifier l’impact.





Source link

Recent Posts