Je souhaite obtenir des informations sur une formation complète concernant le thème DIVI dispensé
par un organisme de formation certifié par l’état.
Que la formation soit finançable par mon CPF (idéalement) ou autre


Avec la mise à jour de WordPress 5.5, un outil de migration appelé jquery-migrate n’était plus activé par défaut. Cela peut entraîner une fonctionnalité médiocre ou un comportement inattendu pour certains thèmes ou plugins qui exécutent un code plus ancien.

Ce plugin sert de solution temporaire et permet au script de migration de votre site de donner à vos auteurs de plugin et de thème plus de temps pour mettre à jour et tester leur code.

Avec la mise à jour de WordPress 5.6, la version incluse de jQuery est également mise à jour. Cela signifie que l’ancien code qui provoquait auparavant des avertissements peut à la place provoquer des erreurs ou cesser de fonctionner.

Certaines des fonctionnalités qui ont cessé de fonctionner ont cessé de fonctionner sans problèmes évidents dans les coulisses.

Avec le plugin, vous pouvez revenir à une version antérieure de jQuery pendant un certain temps. Cependant, en tant qu’administrateur du site, il vous sera demandé de résoudre le problème sous-jacent.

  1. Télécharger généralement dans votre dossier de plugins wp-content/plugins/.
  2. Activez le plugin sur l’écran du plugin.
  3. C’est ça! Le plugin fera le reste pour vous automatiquement.

Qu’est-ce que cela signifie que quelque chose est «obsolète»?

Un script, un fichier ou un autre code est obsolète lorsque les développeurs sont en train de le remplacer par un code plus moderne ou de le supprimer complètement.

Que se passe-t-il après WordPress 5.6?

Avec la sortie de WordPress 5.6, la version jQuery sera également mise à jour. Cela signifie que les plugins ou les thèmes qui provoquaient auparavant des avertissements d’expiration causeront désormais des erreurs à la place.
Ce plugin vous permet de revenir temporairement à la version précédente de jQuery si cela se produit (il essaiera également de le faire automatiquement pour les visiteurs du site Web la première fois qu’une erreur se produit) afin que vous puissiez réparer ou remplacer le code.

Comment trouver et utiliser la console du navigateur?

WordPress.org a un article sur Utilisez le journal de la console du navigateur pour diagnostiquer les erreurs JavaScript.

Le plugin n’enregistre aucun rejet ni ne modifie aucune version de jQuery

Si votre site contient des plugins pour combiner ou charger de manière asynchrone des fichiers JavaScript, ce plugin peut être affecté négativement et ne pas fonctionner comme prévu.

Si votre site nécessite ce plugin, veuillez désactiver tous les plugins qui interagissent avec le chargement de fichiers JavaScript comme les types ci-dessus. Une fois le problème sous-jacent résolu, vous pouvez supprimer ce plugin et réactiver ces autres outils.

Comment savoir si j’ai besoin de ce plugin ou non?

Si quelque chose ne fonctionne pas correctement sur votre site Web après la mise à niveau de WordPress, vous pouvez simplement essayer d’installer et d’activer ce plugin. Si cela vous aide, laissez ce plugin activé et suivez les instructions du plugin. Le plugin vous indique quand vous n’en avez plus besoin.

Il existe de nombreux avertissements obsolètes lors de l’utilisation de jQuery version 3

Étant donné que la version 3 de jQuery est très nouvelle sur WordPress, c’est normal.

Les notifications obsolètes signifient que l’outil de migration est en place pour garantir que ces fonctionnalités continuent de fonctionner pendant que le code associé est mis à jour.

L’activation de ce plugin résout mon problème frontal et le site fonctionne correctement. Cependant, lorsque je me connecte à mon backend, la vitesse de mon site diminue et chaque fois que j’ai « Activer la connexion à la base de données » dans le front-end. Veuillez corriger cette équipe jquery. Mon sujet est l’électro.

Ce plugin est utile pour les sites Web, mais les e-mails hebdomadaires des administrateurs sans option de désinscription agacent les clients et provoquent une panique inutile.

Excellent! .. cela a résolu mes problèmes de barre latérale

Des semaines plus tard et je vois toujours ce foutu message chaque semaine. J’ai exécuté Remove jQuery Migrate, je l’ai même exécuté à nouveau. Je pense que le moyen est d’envoyer les messages au spam

Cela laisse un site Web avec un thème payant qui a été abandonné par le développeur comme prévu. Un correctif rétrocompatible comme celui-ci est important pour que les choses fonctionnent lors de l’application des mises à jour de sécurité. Merci!

J’ai été référé à ce plugin par Qode Interactive (à qui j’ai acheté mon thème) pour résoudre certains problèmes sur mon site Web. Après avoir installé le plugin, mon site Web est devenu complètement corrompu. J’ai essayé de le désactiver et de le désinstaller, mais les effets du plugin ont persisté. J’ai essayé de restaurer à partir d’une sauvegarde mais même cela n’a pas fonctionné !! Finalement, j’ai contacté SiteGround et un agent m’a aidé à identifier que le plugin avait laissé un fichier dans le dossier public_html qui était en dehors de la sauvegarde. Il a supprimé les fichiers de public_html, les a restaurés à partir de la sauvegarde et j’ai vidé mon cache et tout fonctionne à nouveau. Beaucoup d’efforts pour revenir à la première place.

Lisez les 104 avis

« Activer jQuery Migrate Helper » est un logiciel open source. Les personnes suivantes ont contribué à ce plugin.

Contributeurs

v 1.3.0

  • Ajout de l’ancienne interface utilisateur jQuery à charger lors de l’utilisation de l’ancienne jQuery.
  • Ajout de la mention des URL du site dans les e-mails automatiques.
  • Ajout d’une option pour activer / désactiver les rétrogradations automatiques.
  • Une logique a été ajoutée pour garantir qu’une seule demande de rétrogradation est envoyée par chargement de page.
  • Logique mise à jour pour les rétrogradations automatiques afin d’améliorer les performances.
  • Correction d’un bug où les notifications d’expiration de base étaient incorrectement marquées comme des notifications en ligne indéfinies.

v 1.2.0

  • Page de paramètres ajoutée
  • Ajout d’une option pour rétrograder vers l’ancien jQuery
  • Rétrogradations automatiques ajoutées
  • Ajout d’une option pour enregistrer les dévaluations dans jQuery moderne
  • Notifications par e-mail ajoutées
  • Extrait d’e-mail hebdomadaire des dévaluations ajouté
  • Ajout d’une option pour permettre la journalisation des rejets des visiteurs anonymes du site Web
  • La gestion du code JavaScript en ligne a été modifiée, entraînant des messages d’expiration
  • La barre d’administration a été transformée en deux liens physiques pour éviter que les contextes ne changent constamment
  • Les notifications d’administration ont été modifiées après la mise à niveau vers WordPress 5.6 pour être persistantes lors de l’utilisation de jQuery hérité
  • L’enchaînement a été modifié pour résoudre les problèmes de performances accessibles au public
  • La recommandation de supprimer le plugin si aucune dévaluation avec la mauvaise logique n’est enregistrée et n’est pas affichée a été corrigée.

v 1.1.0

  • Ajout d’une option pour ignorer les notifications d’expiration dans le backend
  • Journalisation des notifications d’expiration ajoutées dans le frontend
  • Ajout d’une entrée dans la barre d’administration pour indiquer les dates d’expiration
  • Ajout de la vue de l’amortissement consigné
  • Un avis de tableau de bord a été ajouté pour encourager les utilisateurs à supprimer le plugin si aucune suppression n’a été enregistrée pendant un certain temps (1 semaine).
  • L’intervalle de temps entre l’affichage du tableau de bord nag a été changé de 2 semaines à 1 semaine à mesure que WordPress 5.6 se rapproche.

v 1.0.1

  • La correction de l’une des notifications de l’administrateur ne peut pas être ignorée.

v 1.0.0



Source link

Recent Posts